11/23/2021»»Tuesday

Sierra Unsupported Mac

macOS 10.13 ('High Sierra') became available from the Mac App Store in September 2017. Since the release of macOS 10.14 in September 2018 its support status is unclear.

Installation of High Sierra 10.13 on unsupported Macs. However, I don't believe I'm going to able to do it on the early 2008 machine and earlier. I'll be going for a 2008 MacPro first. Lat year I got the early 2009 machine to Sierra and it was not supported, so we'll hAVE TO SEE. All Late 2009 and later MacBook and iMac models are supported in macOS Sierra, as are all 2010 and newer MacBook Air, MacBook Pro, Mac mini, and Mac Pro computers. Hacking macOS Sierra for Unsupported Macs. Hardware requirements for macOS Sierre include a CPU with SSE4.1, so it cannot be run on any Mac with a CPU prior to the Penryn Core 2 Duo.

So in this article, I will upgrade Mac 2008 to macOS Mojave. Besides that, by upgrading your old version of macOS to latest version you will get the latest features on your Mac computer. For Example from macOS Yosemite too, macOS X El Capitan, macOS Sierra, macOS High Sierra and finally in here you will learn to upgrade in macOS Mojave. All the usual caveats apply: installing macOS Sierra on an unsupported computer could bork it (and your data), as well as likely voiding your warranty. On certain devices, too, the workaround will kill your Wi-Fi functionality. Allow the installation to proceed and the relevant patches will be applied to your unsupported Mac automatically. Apple could always release a future update to macOS 10.15 that prevents the. MacOS Sierra: Apple’s latest desktop operating system is macOS Sierra, All MacBook and iMac models prior to Late 2009 and all MacBook Air, MacBook Pro, Mac mini, and Mac Pro models prior to 2010 are not officially supported by macOS Sierra, but there is a way to install the new software on older, unsupported devices.

Macos shell bash mac preferences apple hackers macos-sierra sierra notification-center brightness macosx pike unsupported unsupported-macs os-x-hackers nightshift night-shift highsierra mojave Updated Jul 31, 2019.

The information below is for historical reference only.

There are some important actions to take before you install it:

  1. Ensure that all the software you are using is compatible with it. See below for a list of known issues.
  2. Verify your hard-disk or SSD before doing the install.
  3. Make sure you have a recent backup, allowing you to recover your data in case of problems.
  4. Note that the upgrade will most likely convert the filesystem on your Mac, carefully read https://support.apple.com/en-us/HT208018 and re-check your backups!

Known Issues

This is a summary of issues known so far. Please note that this list is by no means complete. Please contact the Service Desk if you encounter a problem with an application or a service.

Adobe Illustrator CC

Adobe is reporting about several known issues with macOS 10.13, see https://helpx.adobe.com/illustrator/kb/illustrator-and-mac-os-high-sier…

Auristor Client

Auristor client versions lower than 0.160 are not compatible with macOS 10.13 and must be uninstalled or upgraded before attempting to upgrade to macOS 10.13. Failing to do so will result in endless kernel panic - reboot - kernel panic cycles. We do not recommend to use the Auristor client. Also see the entry for OpenAFS below.

AutoCAD

AutoCAD 2017 can not be installed on a Mac running 10.13, but it might work if it is installed before the upgrade to 10.13

GPGTools

According to https://gpgtools.org (link is external) there is a release of the GPG Suite for macOS 10.13 (GPG Suite 2018.1).

hpglview

hpglview does not work with Xquartz versions above 2.7.9. Xquartz version 2.7.10 or newer is required for compatibility with X libraries on lxplus et al. For the recommened version of Xquartz see below.

MacPorts

MacPorts users should read https://trac.macports.org/wiki/HighSierraProblems, before upgrading to macOS 10.13.

MATLAB

MATLAB versions below R2017b are not compatible with macOS 10.13.

Messenger

Messenger has dropped the support for gTalk.

Microsoft Office

Microsoft Office 2016 requires at least version 15.35 for macOS 10.13.
Support for Office 2011 has stopped in October 10th, 2017.

OpenAFS

We are not aware of a working OpenAFS client for macOS 10.13. The previous versions of openAFS client do not work under 10.13. You must de-install OpenAFS before upgrading to macOS 10.13. Failing to do so will result in endless kernel panic - reboot - kernel panic cycles. Please note that AFS is being phased out at CERN. In the transition period a scp from or to lxplus might be sufficient for infrequent access to AFS files.

Parallels

Parallels has a list of known issues and potential fixes or workarounds on http://kb.parallels.com/123840

ssh

Install Mac Os Sierra Unsupported Mac

Some GSSAPI options have been dropped already in macOS 10.12. Among others the GSSAPITrustDNS is not supported any more. You might have to remove the unsupported options from the system and / or users ssh config files.

In the past we recommended to keep an old version of the ssh binary that still supported GSSAPITrustDNS. This is not needed anymore since lxplus and other major services have now been configured to use service keys. See http://information-technology.web.cern.ch/services/fe/mac-support/howto/configure-ssh-password-less-login-lxplus-or-other-linux-boxen.

How To Download Macos Sierra

System Center Endpoint Protection

Older versions of SCEP do not work on 10.13. Make sure to update your SCEP version 4.5.32. before updating to macOS 10.13.

XQuartz

It is recommended to use XQuartz 2.7.11 or later (https://www.xquartz.org/ (link is external)).

XQuartz installs into /opt/X11, and creates symlinks in /usr. If you have previously installed any version of X11 that did install in /usr, the symlink /usr/X11 -> /opt/X11 cannot be installed, and some X programs will not start. In that case you have to remove the directory /usr/X11 and manually create the symlink.

macOS 10.13 ('High Sierra') became available from the Mac App Store in September 2017. Since the release of macOS 10.14 in September 2018 its support status is unclear.

The information below is for historical reference only.

There are some important actions to take before you install it:

  1. Ensure that all the software you are using is compatible with it. See below for a list of known issues.
  2. Verify your hard-disk or SSD before doing the install.
  3. Make sure you have a recent backup, allowing you to recover your data in case of problems.
  4. Note that the upgrade will most likely convert the filesystem on your Mac, carefully read https://support.apple.com/en-us/HT208018 and re-check your backups!

Known Issues

This is a summary of issues known so far. Please note that this list is by no means complete. Please contact the Service Desk if you encounter a problem with an application or a service.

Adobe Illustrator CC

Adobe is reporting about several known issues with macOS 10.13, see https://helpx.adobe.com/illustrator/kb/illustrator-and-mac-os-high-sier…

Auristor Client

Auristor client versions lower than 0.160 are not compatible with macOS 10.13 and must be uninstalled or upgraded before attempting to upgrade to macOS 10.13. Failing to do so will result in endless kernel panic - reboot - kernel panic cycles. We do not recommend to use the Auristor client. Also see the entry for OpenAFS below.

AutoCAD

AutoCAD 2017 can not be installed on a Mac running 10.13, but it might work if it is installed before the upgrade to 10.13

GPGTools

According to https://gpgtools.org (link is external) there is a release of the GPG Suite for macOS 10.13 (GPG Suite 2018.1).

hpglview

hpglview does not work with Xquartz versions above 2.7.9. Xquartz version 2.7.10 or newer is required for compatibility with X libraries on lxplus et al. For the recommened version of Xquartz see below.

MacPorts

MacPorts users should read https://trac.macports.org/wiki/HighSierraProblems, before upgrading to macOS 10.13.

MATLAB

MATLAB versions below R2017b are not compatible with macOS 10.13.

Messenger

Messenger has dropped the support for gTalk.

Microsoft Office

Microsoft Office 2016 requires at least version 15.35 for macOS 10.13.
Support for Office 2011 has stopped in October 10th, 2017.

OpenAFS

We are not aware of a working OpenAFS client for macOS 10.13. The previous versions of openAFS client do not work under 10.13. You must de-install OpenAFS before upgrading to macOS 10.13. Failing to do so will result in endless kernel panic - reboot - kernel panic cycles. Please note that AFS is being phased out at CERN. In the transition period a scp from or to lxplus might be sufficient for infrequent access to AFS files.

Macos 10.12 Sierra Unsupported Macs

Parallels

Parallels has a list of known issues and potential fixes or workarounds on http://kb.parallels.com/123840

ssh

Some GSSAPI options have been dropped already in macOS 10.12. Among others the GSSAPITrustDNS is not supported any more. You might have to remove the unsupported options from the system and / or users ssh config files.

In the past we recommended to keep an old version of the ssh binary that still supported GSSAPITrustDNS. This is not needed anymore since lxplus and other major services have now been configured to use service keys. See http://information-technology.web.cern.ch/services/fe/mac-support/howto/configure-ssh-password-less-login-lxplus-or-other-linux-boxen.

System Center Endpoint Protection

Older versions of SCEP do not work on 10.13. Make sure to update your SCEP version 4.5.32. before updating to macOS 10.13.

XQuartz

It is recommended to use XQuartz 2.7.11 or later (https://www.xquartz.org/ (link is external)).

XQuartz installs into /opt/X11, and creates symlinks in /usr. If you have previously installed any version of X11 that did install in /usr, the symlink /usr/X11 -> /opt/X11 cannot be installed, and some X programs will not start. In that case you have to remove the directory /usr/X11 and manually create the symlink.

* The “macOS High Sierra Patcher” application is intended for those with unsupported Macs and Hackintosh users, but any Mac user can use the app to be able to download the complete installer file from Apple servers. I am currently researching installing OS X 10.13 High Sierra on unsupported Macs. I did the Sierra upgrade on a couple of MacPros 4,1 and it has worked excellently, after I did a firmware update patch to get it to read as a MacPro 5,1, so I am very optimistic on doing it again.

With macOS Sierra, Apple dropped support for some of its hardware models for the first time in several years. Citing various incompatibilities and hardware deficiencies, they cut out a large swathe of machines from running Sierra. However, many Mac owners have questioned their motives, observing that some machines have made the cut whilst their more powerful contemporaries (such as the MacBook Pro) have mysteriously been left behind.

This led some to conclude that Apple is simply raising the bar to encourage hardware upgrades, and that there is often no incontrovertible hardware reason which dictates the unsupported machines. In many cases this turned out to be true, and with a few tweaks and amendments many of the “unsupported” machines have been brought back into the fold by a tool by dosdude1, called macOS Sierra Patcher. In this guide, we’ll walk you through how to use the tool to install macOS 10.12 Sierra on older Mac hardware, which claims not to support it.

Apple’s hardware requirements for macOS 10.12 Sierra are now as follows:

  • MacBook (Late 2009) onwards
  • iMac (Late 2009) onwards
  • MacBook Air (2010) onwards
  • MacBook Pro (2010) onwards
  • Mac Mini (2010) onwards
  • Mac Pro (2010) onwards

Contrast this with the table below, which shows the additional machines on which Sierra can be installed with the help of macOS Sierra Patcher:

Please note, some machines have issues, as the table reports. The most common is a lack of Wi-Fi due to the unsupported BCM4321 card in some machines, but this can often be replaced. Some machines, such as the MacBook Pro (2008/9), work perfectly with no modifications, leaving you to wonder why Apple thought it necessary to drop them at all.

If you have one of the models listed above and want to give Sierra a try, follow our instructions below to make a modified Sierra installer with Sierra Patcher. Windows 10 usb tool mac.

Instructions to install macOS Sierra on older Macs

1) Find yourself an 8GB or larger USB drive or external hard drive partition.

2) Format it as GUID Partition Map, Mac OS Extended (Journaled) using the Disk Utility application.

Related tutorial:How to use Disk Utility to format drives on your Mac

3) Download a copy of macOS Sierra 10.12. To download this via the Mac App Store you will need access to a supported machine. However, a direct download or a download inside a macOS VM can circumvent this requirement.

4) Ensure the Install macOS Sierra app which you downloaded is in your /Applications folder.

5) Download dosdude’s tool, macOS Sierra Patcher.

6) Disable SIP on the machine you want to install Sierra on. SIP must remain disabled at all times for this method to work, even after initial installation. Do not be alarmed by this. Whilst it does lessen security somewhat, it is not the end of the world, and OS versions prior to El Capitan do not include it anyway.

Related tutorial:How to disable System Integrity Protection

7) Once everything is ready, launch the macOS Sierra Patcher application.

Free screen capture app for mac. Grab, the built-in Mac OS X service that captures screenshots, might be sufficient for most people. If you're looking to pair an upload service to it, you can just add the great and free Cloud App. Snagit combines powerful capture and image editing tools with a quick and easy screen recorder. Screen capture and recording software for Windows and Mac. Screen grab tool free download - Screen Grab Pro, Screen Grab Pro Deluxe, Screen Grab Pro Portable, and many more programs.

8) In the patcher application, click on the Sierra installer icon to select your copy of macOS Sierra. Navigate to your Applications folder and select it.

Apr 26, 2015 The first Snipping Tool alternative for Mac that you can use is Apowersoft Mac Screenshot. This program is designed and created to fit in any device that runs on Mac OS X. This program is designed and created to fit in any device that runs on Mac OS X. Nov 17, 2017 Snipping tool mac is the source of this information. Please go through it and find more information. Sep 12, 2017 4:57 AM Reply Helpful. Thread reply - more options. Link to this Post; User profile for user: lasanthak lasanthak User level: Level 1. The CloudApp Snipping Tool is available for Mac, Windows, iOS and Chrome. Downloading is quick and easy. Access the app from GetCloudApp above, from the Apple Store for Mac and iOS, from the Microsoft Windows Store for PC, or from the Chrome Webstore to add the extension to Chrome. Anki is available for these platforms: Windows, Mac, Linux, FreeBSD, iPhone, and Android. There is also a web-based version of Anki. You are welcome to ask your questions about Anki here, and please help answer other people's questions when you can. Windows snipping tool for mac. Grab is a Mac Snipping Tool alternative that makes it possible to take screenshots of your screen and save them as image files. Just like Snipping Tool for Windows, Grab has several screen-capture modes, and it also supports keyboard shortcuts.

Macos Sierra Unsupported

9) Click the Volume icon to select the drive to create our modified Sierra installer on. Mine is an 8GB USB drive, called USB.

10) When ready, click Start Operation… to begin. Enter your password when prompted. Sierra Patcher will now create a macOS installer on the drive you selected, making edits on the fly so that the resulting installer can be used on unsupported machines.

Once the installer is created, Sierra Patcher will say Complete! and your USB drive should now show as OS X Base System instead of its previous name.

11) Plug the USB installer we just created into the unsupported machine. Turn on the unsupported machine whilst holding down the alt/option key. This makes the machine search for other drives to boot from, in this case, our USB drive.

12) Select the USB installer from the list of drives which appears, to boot from it.

13) Once at the macOS installer, install the OS on your unsupported machine by going through the installer screens and selecting the hard drive in your unsupported machine as the destination. If you’re doing a clean install, use Disk Utility (included in the installer Utilities section) to erase the destination drive first. I recommend doing this for a fresh start. However, if you want to keep the existing installation on the unsupported machine and simply upgrade, run the installer without erasing the drive first.

The installation will now begin. Keep an eye on it, as it will reboot halfway through to complete the installation and you must be ready when it does.

14) When the machine reboots to complete the installation, hold down the alt/option key again to return to the screen pictured in Step 12. If you miss the restart, don’t worry. The machine will try to boot up and fail. Simply hold the power button down until it turns off, then turn it on again. This time, make sure you hold the alt/option key as it boots to get the screen pictured in Step 12.

15) At the boot drive selection screen select the USB installer again (OS X Base System).

16) Once it has booted to the USB installer, we will install the patches we need to make our Sierra installation bootable. This time, instead of launching the Install Sierra utility, launch the utility called macOS Post Install.

17) The Post Install utility should auto-detect your Mac model. Check that it’s correct, and then select it from the drop-down list. The utility correctly identified my machine as a MacBookPro5,5 so that is what I selected from the list. If you’re not sure what model your machine is, search its name and production year to find out, or use the helpful utility Mactracker for Mac or for iOS.

18) Once you’ve selected your model the utility will automatically select most of the relevant patches for your machine. Unless you know what you’re doing I’d leave the rest of it as it is, with one exception. I recommend ticking Recovery Partition Patch as this will make your recovery partition bootable. This is the only must-have patch which is not enabled by default.

19) Make sure the disk to install the patches to is set to your unsupported machine’s hard drive. Mine was called Macintosh HD. Don’t install them to the USB drive or an external hard drive by mistake! When you’re done, click the button to patch the machine and reboot. Please note, you don’t need to select the “Force Cache Rebuild” option which is shown in my picture. This is only useful if your patches do not seem to have taken hold for any reason.

20) As the machine reboots, hold down alt/option one final time. This time, at the boot drive selection screen, do not select the USB drive, select the hard drive of your unsupported machine to boot from. Mine was called Macintosh HD.

The machine will now boot up and finish the installation. Allow it to complete and it should take you into your new Sierra installation on your (supposedly) unsupported Mac. If any of your features such as Wi-Fi or USB are not working after the installation completes, simply reboot to the USB drive again and re-apply your patches once more.

Best tool for programmer mac. Just remember to set it to Simple mode, which is novice-friendly.

And that’s all she wrote!

The patcher is still being updated so you can expect support to continue through future versions of Sierra too. It seems that most users who were running El Capitan will now be able to upgrade after all; everything works perfectly for me on a Mid-2009 MacBook Pro 13″, including features such as Siri. A recent update to the tool also enabled macOS updates to be received through the Mac App Store, so even that aspect is vanilla now.

Please note that if you are using a Hackintosh and not a real Mac then this tool is not needed. All that is required is that you no longer use the SMBIOS of an unsupported machine (for example Mac Pro 3,1). By changing the SMBIOS value the machine will be considered supported, and this tool therefore unnecessary. The patcher is only required for genuine Mac hardware.

Got a machine which was cruelly shunned by macOS Sierra? Let me know whether this guide breathes new life into it.

With macOS Sierra, Apple has once again raised the bar on which Macs can install and run the newest version of the Mac OS. But as sometimes has happened in the past, there are workarounds that make it possible to install Sierra on some unsupported Macs.

A huge thank you to Collin Mistr for developing and sharing his macOS Sierra Patcher Tool for Unsupported Macs. Mistr is a member of our Low End Mac group on Facebook, and he’s been sharing this tool ever since he figured out how to install the first public beta of Sierra. Several members of our group have used the tool and shared their results.

Apple Requirements for macOS Sierra

Your Mac must have at least 2 GB of memory and 8.8 GB of available storage space. You must also be running Mac OS X 10.7 Lion or later. (For those still on OS X 10.6 Snow Leopard, you can upgrade to OS X 10.11 El Capitan for free and then install macOS Sierra.)

  • Late 2009 iMac or newer
  • Late 2009 MacBook or newer
  • Mid 2010 MacBook Pro or newer
  • Mid 2010 Mac Pro or newer
  • Mid 2010 Mac mini or newer
  • Late 2010 MacBook Air or newer

All Macs introduced in the past six years are supported, as well as the consumer MacBooks and iMacs from late 2009, which are almost 7 years old. The official macOS Sierra installer will refuse to install on anything older.

Real Hardware Requirements for macOS Sierra

Again, your Mac needs at least 2 GB of RAM and 8 GB of available storage, and you’ll need a USB drive (thumb drive or hard drive) at least 8 GB in size. You will also need a Mac with an Intel Penryn Core 2 Duo or later CPU, since Sierra requires SSE4.1 – and older versions of the Core 2 Duo, such as Merom, and older Xeon chips (used in the Mac Pro) don’t have it.

mac OS Sierra Patcher Tool for Unsupported Macs supports the followining:

  • Early 2008 Mac Pro or newer
  • Early 2008 iMac or newer
  • Early 2008 MacBook Pro or newer
  • Late 2008 MacBook Air or newer
  • Early 2009 MacBook White or newer

Where Apple only supports some Late 2009 and Mid 2010 Macs, Mistr’s patch supports all Early 2009 Macs, some Late 2008 Macs, and even some Early 2008 Macs. We have a full list of Macs that can unofficially install Sierra using using the Unsupported Sierra tag. We will also be updating these profiles with #unsupportedsierra as time permits.

You Can Install It, But…

That’s a lot more low-end support than Apple offers, so what’s the catch?

There has been an issue with some of the Apple AirPort hardware in older Macs, but other than that, it’s pretty much clear sailing. The AirPort support depends on which WiFi module your Mac uses. If it is not the Broadcaom BCM4321, you’re set.

Other issues include the trackpad in the 2009 MacBooks and loss of volume control on the Early 2008 iMac. Details below.

Unsupported Devices

  • The Broadcom BCM4321 WiFi module used in many older Macs is not supported. You will need to replace it with a compatible module or use a USB WiFi dongle. Models that may have this module include:
    • Early 2008 Mac Pro (MacPro3,1)
    • Early 2009 and Mid 2009 MacBook (MacBook5,2)
    • Early 2008 and Late 2008 MacBook Pro (MacBookPro4,1) but the 15″ Late 2008 MacBook Prois supported
    • Early 2008 iMac (iMac8,1)
    • Early 2009 and Late 2009 Mac mini (Macmini3,1)
    • Late 2008 and Mid 2009 MacBook Air (MacBookAir2,1).
  • The trackpad in the Early 2009 and Mid 2009 MacBooks is not fully supported. Sierra sees it as a standard mouse; you cannot change the trackpad orientation settings.
  • Some Early 2008 iMacs have an audio issue that will not let you adjust sound volume.

Real World macOS Sierra Requirements

Memory

Sure, you can install and run macOS Sierra on a 2 GB Mac, but you’re not likely to be happy with system performance. You have a couple browsers running or several tabs in one browser, and that amount of memory will really hobble performance.

Heck, I find 3 GB on my 2.0 GHz 2007 Mac mini with OS X 10.6 Snow Leopard barely adequate. Then again, I often have 3-4 browsers running, many open tabs, and some additional apps.

My 2.0 GHz Late 2008 Aluminum MacBook has been running OS X 10.9 Mavericks and 10.11 El Capitan decently with 4 GB of memory, and that should be adequate for most users. Power users, however, will want at least 8 GB of memory.

A Fast Drive

Nothing will make your aging Mac seem fast like a Solid State Drive (SSD). Where hard drives are limited in how fast they can read data off a spinning platter, SSDs have no such limitation. Speed is almost completely limited by the speed of the SATA connection in your older Mac. Macs with 1.5 Mbps SATA will seem very fast with an SSD, those with 3.0 Mbps SATA will seem wicked fast, and those with 6.0 Mbps SATA will seem insanely fast.

SSDs have become very affordable over the past year. I have 256 GB and 480 GB SSDs in my Mac mini and MacBook respectively, and they made a world of difference.

If you need really high capacity or are on a very tight budget, look into newer 7200 rpm hard drives to replace your older hard drives. Newer drives tend to be faster and have larger data buffers, which boosts performance.

A third option if hybrid hard drives, which are part hard drive and part SSD. The drive itself manages which files are on the SSD and which remain on the hard drive platters, much like Apple’s Fusion Drive. I have tried hybrid, and while it was nicer than a straight hard drive, it doesn’t compare with a full fledged SSD. For some users in some applications, though, it might be a perfect mix of hard drive capacity and sometime SSD throughput.

In Closing

We Mac geeks have had a long history of hacking Mac OS X to run on unsupported hardware – starting with OS X 10.2. The biggest success was probably the unsupported installer hack for OS X 10.5 Leopard, allowing easy installation on Macs with G4 CPUs below the official 867 MHz threshold.

Collin Mistr’s patch is the same kind of thing for macOS Sierra. If your Mac is not supported by Apple but is by Mistr’s patch, give it a try. I think you’ll like it.

Macos 10.12 Sierra Unsupported Macs

Install Sierra On Unsupported Mac

High sierra unsupported mac

Keywords: #macossierra #unsupportedmacs #unsupportedsierra

Short link: https://goo.gl/InL5NS

Mac Os High Sierra Patcher

searchword: unsupportedsierra

Most Viewed Posts